I just purchase Whatsapp Multi Agent (Time problem)

The time is wrong, I have check with the server (Linux) - WHM / Cpanel
TimeZone Jakarta

Current Time
Mon Dec 9 19:37:13 WIB 2019

On Joomla I also set "Global Configuration" > Website Time Zone
Jakarta

but I saw on Whatsapp Multi Agent > Agent Tab

Current server time is 12:37

which timezone does this module get the time from? This causing starting and ending time setting way off course.

can you help me?
31 responses Add Yours
       
  • Replied by admin on Monday, December 09 2019, 04:30 PM · Hide· #1
    Hi edylai,
    The Current server time information displays the server time in UTC, ignoring the time zone offset .
    So assuming your timezone is Asia/Jakarta (+7), and you want to set an agent to be online at 8.00 AM please set the 'Starting Online at' value to 15.00 (8 + 7)
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by edylai on Wednesday, December 11 2019, 04:01 AM · Hide· #2
    Thanks for the reply,

    but I have check on the linux server hardware time and WHM setting to timezone Jakarta; I also check on joomla the timezone is also Jakarta. How can the module use UTC time?

    Edy
  •  
  • Replied by admin on Wednesday, December 11 2019, 06:46 AM · Hide· #3
    Hi Edy,
    We used the standard Joomla JDate helper class to create datetime object and JDate returned/created a datetime object in UTC format. That's enough for calculating time/duration.

    But I think indeed we need to have a better support for non UTC timezone. So, we’ll try to add it in the near update.

    Anyway have you tried to follow my previous reply about adding more 7 hours in the start date and end date setting?
    Can you tell me whether it’s working good or not?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by edylai on Wednesday, December 11 2019, 09:15 AM · Hide· #4
    I did follow your instruction, it is working fine. But I find another problem on mobile though:

    if the Whatsapp is enabled, my contact form (Located on the top right hand corder "Envelope Icon") stop working from "Shack Form". but if I disabled the Whatsapp, the contact form is working fine.

    If you want to test it, the url is https://laysander.com/mesin-digital-printing

    I have update the Shack form to the latest version, but the problem still persist. do you know any compatibility issues?

    Thanks,

    Edy
  •  
  • Replied by admin on Wednesday, December 11 2019, 09:45 AM · Hide· #5
    Did you mean this form?
    https://www.dropbox.com/s%2Fjy10bsuiekoj3pl%2F70qd9.jpg?raw=1
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Wednesday, December 11 2019, 10:13 AM · Hide· #6
    Can you elaborate what do you mean by "stop working". Do you get any error message?
    I don't have shack form in hand so I can't test it at my end
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by edylai on Thursday, December 12 2019, 04:50 AM · Hide· #7
    I have made video to give better understanding, please get it from my google drive.

    I have contact form from "Shack Form Pro", you can check it on the joomla module on my sites:
    1) 1 module for Mobile version, search "Shack Form Pro", ID 322
    2) 1 module for desktop version, search "Shack Form Pro", ID 371

    if you see on the video:
    1) when Whatsapp module disable, then view https://laysander.com/mesin-digital-printing from mobile screen, then click on envelope, it makes the contact form appear. https://drive.google.com/open?id=1FMgbc4shE4PtrhWczBq5yAq0UMT1ZZhZ

    2) when I enable Whatsapp Module, then view https://laysander.com/mesin-digital-printing from mobile screen, if you click on the envelope the form does not appear https://drive.google.com/open?id=1UZMhqWhRUQQv3_zMOvLsQtNeehPZqBOB

    Thanks,

    Edy
  •  
  • Replied by admin on Thursday, December 12 2019, 06:02 AM · Hide· #8
    Ah I see. I believe it's just a matter of css. Let me check it.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Thursday, December 12 2019, 06:04 AM · Hide· #9
    Umm, It looks like your administrator page is protected by .htaccess/htpasswd.
    So, can you enable the whatsapp module so I can check it?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by edylai on Thursday, December 12 2019, 08:03 AM · Hide· #10
    Hi,

    I have remove the htaccess so you can login,

    Thanks,

    Edy
  •  
  • Replied by edylai on Thursday, December 12 2019, 01:17 PM · Hide· #11
    I also has enable the whatsapp module
  •  
  • Replied by admin on Thursday, December 12 2019, 01:18 PM · Hide· #12
    Hi,
    Yes, thanks! I'm working on it ;)
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by edylai on Thursday, December 12 2019, 01:57 PM · Hide· #13
    It seems to be working now.
    did you make any changes?
  •  
  • Replied by edylai on Thursday, December 12 2019, 02:01 PM · Hide· #14
    sorry, false alarm.
    It was not working when I test on my mobile phone.
    it somehow works for a minute when I turn debug mode on the shack form pro ID 322, in the google chrome with inspect mode.
    but not working on real mobile phone.
  •  
  • Replied by edylai on Thursday, December 12 2019, 02:19 PM · Hide· #15
    I find the problem:
    1. it has to do with auto open. if it is auto open in short time, it cause the shack form pro not to appear when click.
    2. I test and set the Autoopen Time Delay (in miliseconds) to 30000, so it will auto open in 30 seconds, the shack form pro works when I click.
    I think the conflict has to do with the auto pop up.

    Thats what I found so far. right now, I leave the time delay in 30000
    I suggest you look into the coding that do the auto popup.
  •  
  • Replied by admin on Thursday, December 12 2019, 02:20 PM · Hide· #16
    It seems to be working now.
    did you make any changes?
    Yes I have uploaded an updated version with the fix. I found the problem is because the shark form pro uses the class .hide in an unusual way. The .hide class (.hide class is a bootsrapp class which is also used by whatsapp mdoule) is commonly used to hide an object but shark form pro is also using this class when the modal is showing up.
    To resolve this I have changed the name of .hide class for the whatsapp module into .is_hide so it should be working properly now. Please check.
    It was not working when I test on my mobile phone.
    It's working good on my smartphone. Can you try to clear your mobile browser caches first?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Thursday, December 12 2019, 02:22 PM · Hide· #17
    I find the problem:
    1. it has to do with auto open. if it is auto open in short time, it cause the shack form pro not to appear when click.
    2. I test and set the Autoopen Time Delay (in miliseconds) to 30000, so it will auto open in 30 seconds, the shack form pro works when I click.
    I think the conflict has to do with the auto pop up.

    Thats what I found so far. right now, I leave the time delay in 30000
    I suggest you look into the coding that do the auto popup.

    Umm really? I thought it was because of something else (css conflict). Can you re-test it again?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by edylai on Thursday, December 12 2019, 02:23 PM · Hide· #18
    the real problem is the auto popup, if it is set to 30000; even I waited for more than 30 secs, it does not pop up at all.
  •  
  • Replied by admin on Thursday, December 12 2019, 02:28 PM · Hide· #19
    Can you return back the autopopup settings to its defaults (0) and re-test it again?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Thursday, December 12 2019, 02:33 PM · Hide· #20
    Because I don't think the autopopup setting is related to shark form pro setting
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by edylai on Friday, December 13 2019, 06:23 AM · Hide· #21
    Thanks for the information. can I get the updated information on the whatsapp module that already include the .is_hide class?

    Thanks,

    Edy
  •  
  • Replied by admin on Friday, December 13 2019, 06:30 AM · Hide· #22
    Hi Edy, Basically I was just replacing all .hide classname in these files : default.php (including in the javascripts/jaquery calls) and css.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by edylai on Monday, December 16 2019, 09:30 AM · Hide· #23
    I think the timer is not working properly, cause I have disable autopop box, but it still poping up on page load.
    btw, how can I install the whatsapp on my other site? can you tell me exactly which file you change for the hide problem?

    Thanks,

    Edy
  •  
  • Replied by edylai on Monday, December 16 2019, 09:36 AM · Hide· #24
    do you mean that the changes only on this file mod_whatsapp_agent/tmpl/default.php?
  •  
  • Replied by admin on Monday, December 16 2019, 10:08 AM · Hide· #25
    I think the timer is not working properly, cause I have disable autopop box, but it still poping up on page load.
    The timer is not related to autopop setting. It's checking cookie to display autopopup. Which option did you choose for autopopup setting? Is it "Enabled - At the first pageload only" or "Enabled - Infinite, until user click the close button"
    https://www.dropbox.com/s%2F4wi2h9p9vj4qxey%2Fornoj.jpg?raw=1

    btw, how can I install the whatsapp on my other site? can you tell me exactly which file you change for the hide problem?

    I have uploaded the update to templateplazza.com. You can download it from https://www.templateplazza.com/items/whatsapp-multi-agent
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by edylai on Monday, December 16 2019, 04:22 PM · Hide· #26
    Currently I select disable, but it still pop up.
    I have test with 30000, and it still pop up after load not waiting for 30 seconds.

    Thanks for the update.
  •  
  • Replied by admin on Monday, December 16 2019, 11:24 PM · Hide· #27
    Currently I select disable, but it still pop up.
    I have test with 30000, and it still pop up after load not waiting for 30 seconds.

    Strange, if you choose "Disabled" then the "Autoopen Time Delay" setting will be ignored.
    https://www.dropbox.com/s%2Fq3gdcfo32gdz636%2Fgf0d4.gif?raw=1

    I'm also unable to replicate that issue at my end. Please have a look on video screencast below.

    Anyway, I opened your website at https://laysander.com/mesin-digital-printing and I think the module is working properly. The chat widget doesn't pop up as expected. Please have a look on video screencast below. Am I missing something?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by Somedia on Friday, December 20 2019, 12:10 AM · Hide· #28
    Hello
    i have the same problem about the time.
    i change the server time on backend >configuration but nothing change.

    howe we can solved the problem?

    regards
  •  
  • Replied by admin on Friday, December 20 2019, 12:21 AM · Hide· #29
    Hi Somedia,
    As mentioned above, the Current server time information displays the server time in UTC, ignoring the time zone offset
    Can you tell me on what timezone you are in?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by Somedia on Friday, December 20 2019, 03:45 PM · Hide· #30
    Hello
    Timezonme is Germany Europe
  •  
  •  
    Replied by admin on Friday, December 20 2019, 04:01 PM · Hide· #31
    Hi, If your timezone is Germany (+1), and let say you want to set an agent to be online at 8.00 AM, please set the 'Starting Online at' value to 9.00 (8 + 1)
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
Your Response
Please login first in order for you to submit comments