Quote

We're also available for Custom Joomla Development

Hire us now

Latest News Extended not loading image

please check the attachmento file to se the 2 images that are not loading on my website acontece.com
those 2 images are loading in the other extensions on the same page so they are in the article
I have 3 article set in the extension but only the first are showing that problem
Please help
14 responses Add Yours
       
  • Replied by admin on Friday, June 12 2015, 04:09 PM · Hide· #1
    Hi codeware, are you already managed to solve the problem ? I opened your website and the tumbnails looks fine
    https://www.dropbox.com/s/0419tip4h0cxshz/nef0n.jpg?dl=0
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by codeware on Friday, June 12 2015, 05:02 PM · Hide· #2
    no... and that's part of the problem... I checked with a bunch of friends and some can see the images and some cannot... it seems that browser and device type does not influence the result... it's a very weird problem
  •  
  • Replied by admin on Saturday, June 13 2015, 01:57 AM · Hide· #3
    Hmm strange, I don't see any error on that part. Can tell me what browser and device you friends (who cannot see the image) use?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by codeware on Monday, June 15 2015, 10:35 PM · Hide· #4
    I does not show for my friends on any of the browsers they have (GC, FF, IE, safari) and I ask then to test on mobile, mac and pc. One of them is accessing the website from Brazil and the other from Florida.
  •  
  • Replied by admin on Tuesday, June 16 2015, 12:20 AM · Hide· #5
    Hmm strange. Maybe it's just a connection problem?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by codeware on Tuesday, June 16 2015, 05:58 PM · Hide· #6
    is it possible that a connection problem would affect just your extension?
    We really need a solution for this... did you had a change to take a look on it or are you still just collecting info?
  •  
  • Replied by codeware on Tuesday, June 16 2015, 09:20 PM · Hide· #7
    the extension is creating a weird address for the image - that's why the images are not showing http://acontece.com/images/Untitled-1.jpg
    please how can I fix this?

    Attachments:

  •  
  • Replied by admin on Wednesday, June 17 2015, 12:59 AM · Hide· #8
    Hi,
    Really strange. It should be calling a generated thumbnail urls instead of the original url, like this
    https://www.dropbox.com/s/15y5iey4b2v22ch/b07kf.jpg?dl=0

    Can you try to open this file with your php editor :
    root/modules/mod_latestnewsxtd/tmpl/default.php

    at lines 80,82,240,242 :
    you will see this code :

    <img src="/<?php echo lnxtdResizeImageHelper::getResizedImage('/'.$item->image,

    try to change that to
    <img src="/<?php echo lnxtdResizeImageHelper::getResizedImage($item->image,


    or you can also replace that file with this modified file attached below (Please backup first before you replace it)

    Attachments:

    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by codeware on Wednesday, June 17 2015, 12:04 PM · Hide· #9
    it seems the extension is not compatible with non-relative urls... I have to enable the relative urls because I'm having problems to share images on facebook
  •  
  • Replied by admin on Wednesday, June 17 2015, 02:13 PM · Hide· #10
    Hmm does the change I suggested before fix the problem? Can you tell me how did you enable the relative url?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by codeware on Wednesday, June 17 2015, 02:29 PM · Hide· #11
    The problem was solved when I enabled back the relative url on JCE extension. But I did copy your file in the extension folder anyway. But I would like to disable the relative url without having problem with your extension... is that possible?
  •  
  • Replied by admin on Wednesday, June 17 2015, 02:53 PM · Hide· #12
    Ah i see.
    Yes, the module can't generate image thumbnail from external sources (other websites - non relative url) and in your case, when you use non-relative image the module assumes you use an external image and the thumbnail creation will produce an error.
    If you have problem when sharing the content with facebook, I'd like to suggest you to fix from the facebook share function side. Do you use specific module or plugin for the sharing function?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by codeware on Wednesday, June 17 2015, 03:13 PM · Hide· #13
    I'm using this one http://extensions.joomla.org/profile/extension/social-web/social-share/fast-social-share
  •  
  •  
    Replied by admin on Wednesday, June 17 2015, 03:54 PM · Hide· #14
    Have you ever tried to contact the developer regarding the relative url issue before?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
Your Response
Please login first in order for you to submit comments