Minifrontpage white page

Hi

I have installed Minifrontpage version 3.1.0 and it works just fine on all but one page, https://thefireplace.com.au/heating/biofuel-fires/icon-fires which, when Minifrontpage is activated, goes blank and has no source code.

This suggested to me an extension conflict and so I created a "bare bones" page which contains only an article and no other extensions. This page was not a duplicate of another with extensions switched off but was built as a new page. The URL of this page is https://thefireplace.com.au/heating/biofuel-fires/icon-fires-3 and is accessible only to Super Users. I also created a new Minifrontpage module for this page. This page also goes blank with no source code when the Minifrontpage module is activated.

Given that Minifrontpage works on all other pages it cannot be a server problem nor a Joomla version (3.9.10) problem.

Server information is at https://thefireplace.com.au/info.php

Can you assist please?
Resolved
The discussion has been resolved.
13 responses Add Yours
       
  • Replied by admin on Wednesday, March 03 2021, 11:15 PM · Hide· #1
    Hi, this is usually because one of your article has an incorrect image url (image cannot found). It will be fixed in the next update. But in the mean time you can try to check the article that published on that page.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by fritzula on Friday, March 05 2021, 03:55 AM · Hide· #2
    Hi

    These are the only images appearing in the " bare bones" page refered to above:-

    https://thefireplace.com.au/favicon.ico
    https://thefireplace.com.au/heating/biofuel-fires/rgb(255,%20255,%20255
    https://thefireplace.com.au/images/front_page/AHHA_logo_black.png
    https://thefireplace.com.au/media/com_favicon/icons/1/favicon.ico
    https://thefireplace.com.au/templates/g5_hadron/images/logo/preset1/logo.png

    /rgb(255,%20255,%20255 appears odd and appears on all pages but for the home page and without any problems. Using Developer Tools it shows as a missing image and it also appears as a different colour on the contact page {/rgb(0,%20136,%20204). All of the pages are functioning correctly but for https://thefireplace.com.au/heating/biofuel-fires/icon-fires-3. Therefore it cannot be the cause of the problem. /rgb(255,%20255,%20255 does not appear in the source code.

    Each time I tested the pages I cleared the Joomla cache, the expired cache and the browser cache.

    I have replaced the page content with a single letter so there is no article to check.

    Cheers
  •  
  • Replied by fritzula on Friday, March 05 2021, 05:08 AM · Hide· #3
    Now upgraded to version 3.1.1
  •  
  • Replied by fritzula on Friday, March 05 2021, 05:09 AM · Hide· #4
    The problem still exists.
  •  
  • Replied by admin on Friday, March 05 2021, 06:31 AM · Hide· #5
    Hey fritzula,
    I was entering to your administrator page and trying to change the Error Reporting to Development in the Global Configuration to find out what exactly error message returned on the page https://thefireplace.com.au/heating/biofuel-fires/icon-fires-3 ,
    But after I saved the configuration, your website suddenly become inaccessible and returned error
    Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/thefirep/public_html/libraries/joomla/database/driver.php on line 1956

    I'm trying to return back the Error reporting to Default by editing the configuration.php file but the credentials you provide above doesn't let me in to ftp. So if you can, please open the file configuration.php, change back the line
    public $error_reporting = 'development';
    into
    public $error_reporting = 'default';
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Friday, March 05 2021, 06:40 AM · Hide· #6
    I was able to enter your website via ftp and change the error reporting setting to default. And seems everything goes back to normal.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Friday, March 05 2021, 06:49 AM · Hide· #7
    I'm a little afraid to make some tests on your website because of recent error experience :D
    Anyway what php version do you have on your website? Is your Joomla website is upgraded from Joomla 2.5 before?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by fritzula on Friday, March 05 2021, 11:32 AM · Hide· #8
    Do not be concerned about breaking something. I have just now made an Akeeba backup.

    PHP version is 7.4

    Joomla is version 3.9.10
  •  
  • Replied by fritzula on Saturday, March 06 2021, 04:06 AM · Hide· #9
    I cannot recall if the site was upgraded from 2.5 but, given the size of the site, I would think that it was.
  •  
  • Replied by admin on Saturday, March 06 2021, 04:44 AM · Hide· #10
    I cannot recall if the site was upgraded from 2.5 but, given the size of the site, I would think that it was.
    I think so because the previous error message is something that will probably occur in joomla 2.5. Ok I'll have a look again to your website and back to you very soon
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Saturday, March 06 2021, 05:45 AM · Hide· #11
    Hi I think your website indeed an upgrade from 2.5 because you have atom template in templates directory.
    Anyway, I tried to change the template for menu https://thefireplace.com.au/heating/biofuel-fires/icon-fires-3 to protostar and finally I got the error message. It said that you have no GD library enabled. It's a bit strange because GD is usually enabled in the standard web server installation.
    https://www.dropbox.com/s%2Fkbye42tkruuqhi4%2FError%25200%2520The%2520GD%2520extension%2520for%2520PHP%2520is%2520not%2520available.%25202021-03-06%252012-40-41.png?raw=1
    Can you check it why GD is not enabled in your server?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by fritzula on Saturday, March 06 2021, 07:09 AM · Hide· #12
    Hi

    I have enabled php74-php-gd and all now appears OK. PHP74 was installed about a month or two ago without any indication of an error. For your information I have now checked PHP73 and it also did not have the gd graphics library installed which is, of course, the reason why, when I tested the problem in PHP73, it came up the same as PHP74. I did not test PHP72.

    It's odd, though, that only one page was effected.

    Thank you for your assistance, much appreciated.

    Cheers
  •  
  •  
    Replied by admin on Saturday, March 06 2021, 08:32 AM · Hide· #13
    ok glad could help
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
Your Response
Please login first in order for you to submit comments