Quote

We're also available for Custom Joomla Development

Hire us now

Play a youtube video on page load

Can you please explain in detail, how to do this using the modal in module install?
10 responses Add Yours
       
  • Replied by admin on Saturday, July 23 2016, 05:48 PM · Hide· #1
    I have created a simple module for you to make it easier for you to embed youtube videos inside a module. Please try it

    Attachments:

    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by KPlummer on Saturday, July 23 2016, 12:08 PM · Hide· #2
    OK, I am sorry but I am at a loss here..... What do I need to run the video? Can you suggest a module, plugin, or whatever.... Thank you for your time on this.
  •  
  • Replied by admin on Saturday, July 23 2016, 10:28 AM · Hide· #3
    Hi, I see that you're using tag {youtube}RfMyJg2cG2c{/youtube} to call youtube video. Are you sure that tag is working with custom module? Isn't it just for using with article?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by KPlummer on Friday, July 22 2016, 07:36 PM · Hide· #4
    Can you check that it is working, I have the youtube code working on an article see video introduction link on main menu.
  •  
  • Replied by admin on Thursday, July 21 2016, 05:42 PM · Hide· #5
    Hi, It's because the module isn't assigned yet. https://www.dropbox.com/s/nxcwi9fnzjbixyh/menuassignment.jpg?raw=1
    I have assigned it to "All pages" and modal in module is already working now, but your youtube code is not working yet. You need to fix the youtube code
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by KPlummer on Thursday, July 21 2016, 05:21 PM · Hide· #6
    checked that and rechecked everything, I have it set to every pageload. Still nothing.
  •  
  • Replied by admin on Thursday, July 21 2016, 06:55 AM · Hide· #7
    Anyway, please check this two things before it :
    - If the 'Modal Trigger' is set to ' Opened once per visitor' then you will only the module once too. You won't see the module until you cleared your broswer caches / cookies, or you can set it to 'Opened on every page load' while testing the module.
    - Please make sure the 'Modal in Module' itself is published, and assigned to diffreent modulu position with the module you want to display (not in 'position-modal'')
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Thursday, July 21 2016, 06:49 AM · Hide· #8
    Hi, Is it possible for you to provide temporary access to your website so I can check it by myself? If it's possible you can enter the details using the "You Site Details" tab below. Only support team who are able to see that.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by KPlummer on Thursday, July 21 2016, 03:03 AM · Hide· #9
    Something is missing as I followed the steps exactly and got nothing.
  •  
  •  
    Replied by admin on Thursday, July 21 2016, 01:38 AM · Hide· #10
    Hi, Kevin. Please follow these steps :
    1. Create a new custom html module with joomla then embed your youtube video inside it ( or you can also use any other youtube module).
    2. Publish the module and assign it to a module position, let say 'position-modal'
    3. Install module in modal
    4. In the Module in Modal backend set the parameter into this :
    Modal Trigger : Page On load
    Modal Trigger : Opened once per visitor.
    Content Source : module-position
    Module Position : position-modal
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
Your Response
Please login first in order for you to submit comments