Pop Log In and jquery

All of a sudden getting warnings from pop log in that jquery is not loaded and that we need to enable it in the module's advanced settings.

I see no setting to enable that.

Ideas?

Thanks
Resolved
The discussion has been resolved.

Accepted Answer

  • Replied by CCANSW on Thursday, July 01 2021, 12:29 AM
    All good. Got my head around it now.

    Cheers

     
  • Replied by admin on Monday, June 28 2021, 07:18 AM · Hide· #1
    Hi, It's alert for the old jQuery version 2.5 actually. In joomla 3, jQuery is commonly added from the template side. Does your template have jQuery loaded?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by CCANSW on Wednesday, June 30 2021, 12:45 AM · Hide· #2
    Hi
    Thanks for the reply.
    I'm finding this jquery stuff very confusing, especially since working my way through a number of performance related issues on a large website I maintain. That's mostly resolved now, but I don't get the lack of clear direction on jquery versioning.

    You mention jquery version 2.5 being very old, but most of the current joomla stuff I'm reading regarding jquery references jquery version 2.2. Other reading suggests Joomla 3.n is packaged with jquery version 1.12.4. I assume that's to favour earlier internet explorer browsers (?).

    It's doing my head in, but I'll persevere.

    Cheers
  •  
  • Replied by admin on Wednesday, June 30 2021, 12:49 PM · Hide· #3
    Sorry I mean that alert's code is inherited from the poplogin banner for joomla 2.5 version (I must be forgot to removed it) while the poplogin banner for joomla 3 no longer asking jQuery, because In joomla 3, jQuery is commonly added from the template side.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by CCANSW on Thursday, July 01 2021, 12:22 AM · Hide· #4
    Our template loads CMS jquery.
  •  
  •  
    Replied by CCANSW on Monday, July 19 2021, 03:45 AM · Hide· #5
    FYI, the problem continues intermittently for many of our users, although we are confident our template is loading jquery correctly.

    I've had to disable the module due to too many complaints


    Thanks
Your Response
Please login first in order for you to submit comments