Related item Extended ans SH404SEF

Hi,
Sometimes (often) I have a problem with Related item Ext and SH404SEF, the links are not modified by SH404SEF.
I guess it must a execution order problem but I don't know how to fix that ?
On every article page I have the module and sometimes the links stays with the default Joomla structure.
Ex : https://www.360images.fr/visites-virtuelles/auvergne/volcans-d-auvergne-la-chaine-des-puys.html

A clue ?
16 responses Add Yours
       
  • Replied by admin on Tuesday, March 30 2021, 01:06 PM · Hide· #1
    Hmm Related Items Extnded module generates the link using standard joomla JRoute API. It should be no problem actually.
    Anyway, can you try to create a Category List menu for the articles and then see whether the links is changed?
    https://www.dropbox.com/s%2Fhv6e26himy4vgqo%2FMenus%2520New%2520Item%2520-%2520J39%2520-%2520Administration%25202021-03-30%252020-05-59.png?raw=1
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by jeromebg on Tuesday, March 30 2021, 02:07 PM · Hide· #2
    Category list works alright.
    Just realized that I had Joomla core cache enabled while I'm using JotCache plugin, maybe this where the bug comes from ?
  •  
  • Replied by admin on Tuesday, March 30 2021, 02:15 PM · Hide· #3
    Category list works alright.
    Ah ok glad it works ;)
    Just realized that I had Joomla core cache enabled while I'm using JotCache plugin, maybe this where the bug comes from ?
    I don't think so, but I'm not really sure about that.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by jeromebg on Friday, April 02 2021, 08:26 AM · Hide· #4
    Well, problem is not solved, on some page the related articles links urls are not transformed by SH404SEF.
    If I clear all cache manually it works, but when cache is updated auto (every 2 days) then problem comes back.
    For example : https://www.360images.fr/visites-virtuelles/new-york/ponts-de-brooklyn-et-manhattan.html
    The 3 thumbnails links at the bottom (related item module) are not transformed correctly : category is transformed but not article html page.
    https://www.360images.fr/visites-virtuelles/new-york/index.php?option=com_content&view=article&id=287:rooftop-bar-230-fifth&catid=62
    should be
    https://www.360images.fr/visites-virtuelles/new-york/rooftop-bar-230-fifth.html

    A clue ?
  •  
  • Replied by admin on Friday, April 02 2021, 08:34 AM · Hide· #5
    Are you sure you have created hidden menus for all of your article categories?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by jeromebg on Friday, April 02 2021, 08:47 AM · Hide· #6
    What for ?
    Main menu has a link to each article category (blog display).
    By the way I never had this issue with older version of related item ext module (when a plugin was associate)
  •  
  • Replied by admin on Friday, April 02 2021, 09:06 AM · Hide· #7
    Main menu has a link to each article category (blog display).
    I see.
    What for ?
    Because there's a common sef issue in joomla that can be easily fixed by creating category menu.

    By the way I never had this issue with older version of related item ext module (when a plugin was associate)
    The codebase of the new version is almost identical with the old one. They are both based on the joomla standard related articles module. And the new version is based on the new and updated codebase of joomla standard related articles module.

    Anyway, in the Basic Settings, what Relation setting do you have? Is it Meta Keyword or Tag?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by jeromebg on Friday, April 02 2021, 09:10 AM · Hide· #8
    Tag
  •  
  • Replied by jeromebg on Friday, April 02 2021, 09:12 AM · Hide· #9
    ok, I just cleared the cache manually and it works again as expected...
    So I guess it has something to do with auto clearing cache when expired ?
  •  
  • Replied by admin on Friday, April 02 2021, 09:35 AM · Hide· #10
    I'm not sure about that. Do you have any other 3rd party cache extension installed?

    Tag

    Can you try to publish a Joomla module Tags - Similar and check whether the module does have the similar issue or not?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by jeromebg on Friday, April 02 2021, 11:29 AM · Hide· #11
    Thanx for your support !
    I added the similar tag module, cleaned the cache and all was working perfect.
    Now I go back one hour after to check and same issue, but the similar tag module still works as expected :
    https://www.360images.fr/visites-virtuelles/paris/les-plus-belles-stations-de-metro.html
    Very strange, works on some pages still...
  •  
  • Replied by admin on Friday, April 02 2021, 12:35 PM · Hide· #12
    Hmm Can you share temporary access to your website so I can have a look on it directly? If you can, you can share it in the Your Site Details tab below. Only you and support staffs who are able to see it.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by jeromebg on Friday, April 02 2021, 12:43 PM · Hide· #13
    Yes, thx for your support
  •  
  • Replied by admin on Friday, April 02 2021, 12:52 PM · Hide· #14
    I have added a template override for the module and added some modifications. Can you monitor it for few hours and let me know whether the issue still persist or not?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by jeromebg on Friday, April 02 2021, 12:54 PM · Hide· #15
    Sure I will, thx for your time !
  •  
  •  
    Replied by admin on Saturday, April 03 2021, 02:19 PM · Hide· #16
    Anyway, we have uploaded the update (version 2.2.0) which includes the fix for sef issue. You can remove the template override then update your module installation to the latest one.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
Your Response
Please login first in order for you to submit comments