Quote

We're also available for Custom Joomla Development

Hire us now

Related Items Extended - CSS problem

Hello,
I have a problem with items displaying - sometimes it looks weird.
See attachment, please.
Resolved
The discussion has been resolved.
12 responses Add Yours
       
  • Replied by Shadrova on Monday, February 08 2016, 07:23 AM · Hide· #1
    Anybody here?
  •  
  • Replied by admin on Monday, February 08 2016, 01:02 PM · Hide· #2
    HI, Can you let me know the URL of your site so I can take a look?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by Shadrova on Monday, February 08 2016, 01:54 PM · Hide· #3
    Localhost.
    This is a quite random error. It happens not every time.
  •  
  • Replied by admin on Monday, February 08 2016, 02:05 PM · Hide· #4
    Hmm it's quite hard to find the solution without seeing the problem correctly. Can you let me know your module parameters so I can try to replicate the problem at my end?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by Shadrova on Monday, February 08 2016, 02:16 PM · Hide· #5
    Layout Type - Default
    ------------------------------------ Related Items Source ----------------------------------
    Related Items based on - Meta Keywords
    ------------------------------------ Layout and Content ------------------------------------
    Count - 5
    Order by - Random
    Select Category - My List of categories
    Period of Novelty (Days) - 365
    Show Header Text - Yes
    Category Title - None - Default
    Item Title - H3
    Show thumbnails - Yes
    Show Intro Text - No
    # Introtext Item - 5
    # Skipped Introtext - 0
    Limit intro text characters - 200
    Show Meta - None
    Show Date Type - Short Month/Day/Year (MM/DD/YYYY)
    Show Read more - No
    ------------------------------------ Default Layout Properties ------------------------------------
    # Columns - Single - Default
    ------------------------------------ Slideout Layout Properties ------------------------------------
    Slideout Box Width - 350
    Slideout Box Height - 150
    Items Display - Tabs
    --------------------------------- Thumbnail Properties ---------------------------------
    Location - Left - Default
    Show Border - None
    Link to Article - No
    Thumbnail Image Width - 75
    Thumbnail Image height - 75
    Resize Option - Crop
  •  
  • Replied by admin on Monday, February 08 2016, 02:47 PM · Hide· #6
    Can you try to add this code to your css file :
    .ac header {
    display:block!important;
    white-space:nowrap!important;}
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by Shadrova on Monday, February 08 2016, 02:50 PM · Hide· #7
    Horizontal scroll is appearing 'cause nowrap.
  •  
  • Replied by admin on Monday, February 08 2016, 03:28 PM · Hide· #8
    Horizontal scroll is appearing 'cause nowrap.
    Try to add overflow:hidden to the module wrapper.

    I think the problem is because sometimes the article title is too long so the module wrapper push the title so it's displayed at the below of the thumbnail.

    Alternative solution, maybe you can also try to decrease the font size for the title
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by Shadrova on Monday, February 08 2016, 03:34 PM · Hide· #9
    I think the problem is because sometimes the article title is too long

    No, look at the attachment $3.
    Try to add overflow:hidden to the module wrapper.

    Are you kidding me? It is NOT a solution for commercial extension.
  •  
  • Replied by admin on Monday, February 08 2016, 04:07 PM · Hide· #10
    Are you kidding me? It is NOT a solution for commercial extension.
    I'm not kidding, from your previous answer about how" horizontal scrolling appearing because of nowrap" I was assuming you know about css and know how to add code to css. And also I don't know about your html structure because your website is still on localhost so I don't know what tag or class is wrapping the module so I can't suggest you the proper code. But if you want to try you can use this code :
    .class_name_of_your_module_wrapper .ac {
    overflow:hidden!important;}
    or if you have no idea about the 'class_name_of_your_module_wrapper' you can try to use
    .ac {
    overflow:hidden!important;}
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by Shadrova on Monday, February 08 2016, 04:16 PM · Hide· #11
    I don't want to use property "overflow:hidden" taking a part of content invisible.
    because sometimes the article title is too long

    Are you serious? Are there any restrictions on title length?
  •  
  •  
    Replied by admin on Tuesday, February 09 2016, 12:19 AM · Hide· #12
    Hi, try this one
    .ac header {
    display:block!important;
    word-break: break-all!important;
    }
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
Your Response
Please login first in order for you to submit comments