vkroustallis on Monday, January 10 2022, 02:47 PM

Related Items extended shows no images

HI, I'm newbie here.

Just to know what I'm doing wrong with Related Item. It won't show any thumbnails at all, no matter how many times I delete the thumbnails from the folder and empty the cache browsser (Joomla 3.4.9).

I have the attachments here. So if anyone can help, it would be welcome.

Best,

Vassilis
33 responses Add Yours
       
  • Replied by admin on Saturday, January 15 2022, 09:57 AM · Hide· #1
    wow that's really really strange ... But I'm glad that the issue is now resolved. Please update me if you found any other issue later
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by vkroustallis on Saturday, January 15 2022, 08:09 AM · Hide· #2
    Can't really tell about the extensions, even though I don't have a specific extensions to do that. But I did the following.

    I went to the 'Manage' section and I removed instances of Related Items XTD. It seems that some instances of the previous version (1.1) were there as well. So, I removed everything I could (there are still things from the 1.1. version that could not be removed), so I just unpublished them.

    I re-installed Related Items XTD, and now it works! I tried both "All Pages" and then specific pages (excluded it from Sign-in pages etc). So, the Festivals page is now fine.

    I haven't tried anything apart from the default mode, but I think I'll leave it there. Don't want another round.

    So yes, I think everything's OK now -for the time being :)
  •  
  • Replied by admin on Saturday, January 15 2022, 02:25 AM · Hide· #3
    That’s exactly what happened when I tried to create single menu item with protostar template assigned. Do you have any extension installed that is probably responsible for override url routes or maybe something related to that?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by vkroustallis on Friday, January 14 2022, 01:42 PM · Hide· #4
    I had a menu item using single article parameters. I'm not sure whether something else (category?) overrides this. Here's the screenshot
  •  
  • Replied by admin on Friday, January 14 2022, 11:55 AM · Hide· #5
    I opened that link but it seems that page still using the default template,not protostar?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by vkroustallis on Friday, January 14 2022, 11:32 AM · Hide· #6
    Ok, I did that. Assigned the module also to this menu (protostar).

    Looks the same to me

    https://www.zippyframes.com/production/european-feature-animation-report
  •  
  • Replied by admin on Friday, January 14 2022, 10:39 AM · Hide· #7
    Hmm It's really strange. The module now even didn't load in the pages where it loaded before. I switched back the RelatedItemsXtdHelperTag.php file to the original one (by re-uploading the module) but the issue persist. I also set the error reporting to Development but no error message displayed. Really strange.
    Anyway, can you create a new menu item that is using single article then assign protostart template to that menu item? I want to check whether this is something related to template or something else. I was trying to create that menu item under hidden menu but the link is always overrided by other menu (not sure why, maybe you have an extension installed for that).
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by vkroustallis on Friday, January 14 2022, 09:37 AM · Hide· #8
    You can do that.
  •  
  • Replied by admin on Friday, January 14 2022, 09:25 AM · Hide· #9
    Anyway, Is it ok if I clear the joomla cache of your website anytime I need to?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Friday, January 14 2022, 09:24 AM · Hide· #10
    Let me check it again and will back to you very soon.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by vkroustallis on Friday, January 14 2022, 09:16 AM · Hide· #11
    So, is there anything else we can do? Or shall I stop using the module in this website? Since it won't appear anyway.
  •  
  • Replied by admin on Friday, January 14 2022, 09:06 AM · Hide· #12
    so it is never an empty folder
    Yes maybe it because your website is live so the module keep generating thumbnails because someone (your web visitor) opening a page in the frontend
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by vkroustallis on Friday, January 14 2022, 09:03 AM · Hide· #13
    I did clear cache.

    I try to delete all images, but the moment I do that, new thumbnails re-appears, so it is never an empty folder
  •  
  • Replied by admin on Friday, January 14 2022, 08:42 AM · Hide· #14
    Now it appears nowhere at all, whether I put selected pages or all pages
    Have you tried to clear your cache first?
    And also please delete all images under this folder so the module can re-create new thumbnails : /images/thumbnails/mod_relateditems_xtd
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by vkroustallis on Friday, January 14 2022, 08:34 AM · Hide· #15
    Hi, I did that.

    Now it appears nowhere at all, whether I put selected pages or all pages
  •  
  • Replied by admin on Thursday, January 13 2022, 03:32 PM · Hide· #16
    a) In the festival category, the related articles now appear, but they are the same 4 articles everywhere, regardless of tags.
    I think it's because you enabled the joomla cache. Try to disable module caching in the module settings page
    https://www.dropbox.com/s%2F2j6bvrfo589eatt%2Fmodules%2520mod_relateditems_xtd%2520-%2520j39%2520-%2520administration%25202022-01-13%252022-30-22.png?raw=1


    b) In the other categories (for instance, shorts), it says undefined property (check screenshot)


    Can you try to edit the file /modules/mod_relateditems_xtd/Helper/RelatedItemsXtdHelperTag.php at lines 92-93 you will see this code :
    $db->quoteName('c.introtext'),
    $db->quoteName('c.catid'),


    try to change that to

    $db->quoteName('c.introtext'),
    $db->quoteName('c.modified'),
    $db->quoteName('c.catid'),
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by vkroustallis on Wednesday, January 12 2022, 10:12 AM · Hide· #17
    OK, I did that. Two issues

    a) In the festival category, the related articles now appear, but they are the same 4 articles everywhere, regardless of tags.

    b) In the other categories (for instance, shorts), it says undefined property (check screenshot)

    https://www.zippyframes.com/shorts/flowing-home-sandra-desmazieres
  •  
  • Replied by admin on Wednesday, January 12 2022, 10:01 AM · Hide· #18
    Hmm really strange I'm still unable to spot the issue. Anyway, I see you use jch optimize, can you try to clear all of your cache and then set the Error Reporting level to Development , then open the page : https://www.zippyframes.com/festivals/annecy-festival-2022-celebrates-swiss-animation to see if there is any specific error message?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Wednesday, January 12 2022, 09:32 AM · Hide· #19
    Let me check it again. Please stay tuned
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by vkroustallis on Wednesday, January 12 2022, 09:21 AM · Hide· #20
    I published a custom module in the same module position as Related Articles Extended. I experimented with both a) all pages selected and b) only few pages selected. It appears on the festival menu as well in both cases - looks fine.d

    I also duplicated the Related Items Extended module to another module position to check if perhaps this module position was problematic. The same problem appears (not shown on the Festival menu).
  •  
  • Replied by admin on Wednesday, January 12 2022, 01:00 AM · Hide· #21
    Really strange ... Does this only happen with related extended modules? Or to all modules published on the same position? Can you check it?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by vkroustallis on Tuesday, January 11 2022, 02:24 PM · Hide· #22
    I did assign the module to all pages. It did exactly the opposite, it disappeared from all pages - nowhere shown. So, I reinstated the selected pages settings.
  •  
  • Replied by admin on Tuesday, January 11 2022, 01:53 PM · Hide· #23
    Can you temporarily try to make the module is published on all pages to see whether the module is displayed or not? I think this is something related to module assignment as indeed the module is not loaded in those articles (under Festival)
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by vkroustallis on Tuesday, January 11 2022, 07:55 AM · Hide· #24
    OK, sent administrator details.Please don't update extensions before letting me know.

    If there's any problem logging in, let me know as well.

    Vassilis
  •  
  • Replied by admin on Monday, January 10 2022, 10:35 PM · Hide· #25
    Can you share temporary access to your website so I can have a look on it directly? If you can, you can share it in the Your Site Details tab below. Only you and support staffs who are able to see it.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by vkroustallis on Monday, January 10 2022, 04:42 PM · Hide· #26
    Yes, they do. They've been categorized by tag, and all of them have corresponding articles.

    They are all part of the same category "Festivals", which in turn is invoked in the corresponding menu "Festivals & Awards"

    No article from this category and menu has any Related Items shown at the front end.
  •  
  • Replied by admin on Monday, January 10 2022, 03:54 PM · Hide· #27
    Are those articles having related item/article?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by vkroustallis on Monday, January 10 2022, 03:36 PM · Hide· #28
    Ok, I did that. Now looks fine.

    But I discovered another issue. It won't appear in some menus, even though I ticked those in menu assignment

    Like here: https://www.zippyframes.com/festivals/jury-anima-2022

    https://www.zippyframes.com/festivals/island-anca-damian-iffr

    (FESTIVALS & AWARDS Menu)

    Attachments:

  •  
  • Replied by admin on Monday, January 10 2022, 03:17 PM · Hide· #29
    I opened this page and it looks like the related module is working properly : https://www.zippyframes.com/interviews/true-north-interview-with-eiji-han-shimizu
    The only issue is the thumbnails looks blurry, maybe you want to increase the size of thumbnail in the module backend.

    https://www.dropbox.com/s%2F3sb2e1dbjholpyz%2Ftrue%2520north%2520interview%2520with%2520eiji%2520han%2520shimizu%25202022-01-10%252022-14-09.png?raw=1
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by vkroustallis on Monday, January 10 2022, 03:11 PM · Hide· #30
    http://www.zippyframes.com
  •  
  • Replied by admin on Monday, January 10 2022, 03:06 PM · Hide· #31
    Ah I see. Can you tell me your website url so I can check it?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by vkroustallis on Monday, January 10 2022, 03:03 PM · Hide· #32
    Oops, sorry, I gave you the wrong Joomla version!

    It's Joomla 3.10.2 at the moment
  •  
  •  
    Replied by admin on Monday, January 10 2022, 02:54 PM · Hide· #33
    Hi, the module requires at least Joomla 3.7.x to work, is it possible for you to upgrade your joomla to the latest version first?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
Your Response
Please login first in order for you to submit comments