Quote

We're also available for Custom Joomla Development

Hire us now
madd on Thursday, December 29 2016, 06:12 PM

Responsive Banner - nivo caption text not hyperlinked

is there any way for the caption text to act as a hyperlink along with the image with using the nivo style pls? Given the size (height) of the caption area, I've noticed that only about 50% of my image can be clicked. I've reduced the caption area and text a bit but it would be great if the text/caption acted as a hyperlink as well. thanks
       
  • Replied by admin on Friday, December 30 2016, 04:57 PM · Hide· #1
    Yes. The settings looks good, except the 'Background Image' field. It shouldn't be there. Did you modify the script?
    Anyway can you tell me what value you have for 'Target' field? Is it Open in new window or Open in parent window?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by madd on Friday, December 30 2016, 02:36 PM · Hide· #2
    not sure I completely understand. Do you mean this screenshot?
  •  
  • Replied by admin on Friday, December 30 2016, 01:10 PM · Hide· #3
    Can you provide an image screenshot of your module backend settings? I want to make sure we edit the correct part of the default.php file
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by madd on Friday, December 30 2016, 12:42 PM · Hide· #4
    doesn't appear to work for me - I've tried viewing in different browsers and clearing cache...
  •  
  • Replied by madd on Friday, December 30 2016, 12:28 PM · Hide· #5
    thanks - I'll give it a go and let you know.
  •  
  •  
    Replied by admin on Friday, December 30 2016, 01:23 AM · Hide· #6
    Hi,
    That part is actually generated by nivo javascript, but there's a workaround if you want to try.
    Open the file ../modules/mod_responsivebannerslider/tmpl/default.php with your php editor, at line 143 you will see this code :
    <a
    	href="/<?php echo $link; ?>" target="_blank"
    	title="<?php echo htmlspecialchars($item->name, ENT_QUOTES, 'UTF-8');?>">
    	<img
    		src="/<?php echo $baseurl . $imageurl;?>"
    		alt="<?php echo $alt;?>" <?php if (($show_caption == 1) && ($sliderType == 1)) {echo 'title="<span>'.htmlspecialchars($item->name, ENT_QUOTES, 'UTF-8') .'</span><br /><i>'. $alt.'</i>"';}?>
    
    	/>
    </a>


    try to change that part to :

    <a
    	href="/<?php echo $link; ?>" target="_blank"
    	title="<?php echo htmlspecialchars($item->name, ENT_QUOTES, 'UTF-8');?>">
    	<img
    		src="/<?php echo $baseurl . $imageurl;?>"
    		alt="<?php echo $alt;?>" <?php if (($show_caption == 1) && ($sliderType == 1)) {echo 'title="<a href='.$link.'><span>'.htmlspecialchars($item->name, ENT_QUOTES, 'UTF-8') .'</span><br /><i>'. $alt.'</i></a>"';}?>
    
    	/>
    </a>
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
Your Response
Please login first in order for you to submit comments