Quote

We're also available for Custom Joomla Development

Hire us now

"Undefined property" error in Related Items Extened

On some of my pages, The RIE gives an error, "Undefined property" (see e.g. http://ehinger.nu/undervisning/index.php/starta-haer/nyheter/5535-kaskeloter-i-sodra-stilla-havet.html under "Läs också..." and "Också intressant"). It seems the error appears when the first link in the linked related article is to a Youtube video, or when there aren't enough related articles to link to.

What might be the cause of this error?

/Magnus
       
  • Replied by admin on Monday, June 30 2014, 06:30 AM · Hide· #1
    Hi , Sorry for delay in responding due to weekend offline.
    In regards to your problem, if no image exist on the article the module will display default image like this :
    https://www.dropbox.com/s/d36v8maoyuaj0aw/mh1i4.jpg

    Can you tell me how did you add the youtube video to your article?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by mehinger on Monday, June 30 2014, 06:56 AM · Hide· #2
    Unfortunately, this is not a problem of displaying an "empty image", but an error message.

    I think the problem lies in the related article "Förhistorisk 'valkyrkogård' funnen" (http://ehinger.nu/undervisning/index.php/starta-haer/nyheter/1198-notiser/4122-foerhistorisk-valkyrkogard-funnen.html). The first (only) image in this article is a popup (made in JCE), and surrounded by href anchors. See code example in the attached file.

    The Youtube videos were added with the standard Youtube method, with an iframe. Since RIE doesn't extract images automatically from Youtube (this is on my wish list!) ;) I added the images manually to the articles.
    • mehinger - more than a month ago
      (Did the text file upload? I can't see it.)
  •  
  • Replied by admin on Monday, June 30 2014, 07:05 AM · Hide· #3
    Ah, that's probably the reson of your problem. Please try to remove the link for the image.
    Related Extened module will first find the first image in the article, if not found then it will find image in intro image, if still not found it will find image on full article image. If still not found it will display a default image.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by mehinger on Monday, June 30 2014, 07:19 AM · Hide· #4
    Yes, but don't you think this is a bug that needs to be corrected? Instead of displaying an error message when an image is surrounded by href tags, it would be much nicer if the image itself was shown. ;)

    On my site, nearly all of my images are popups. To fix my problem, I have to put another copy of the image first in the article, but with width=0, so it doesn't show twice.

    Also, many of the images are embedded from around the 'net, and not located on my server. So, to further extend my wish list for RIE, I would like embedded images to be shown by RIE, too. :)
  •  
  •  
    Replied by admin on Monday, June 30 2014, 07:39 AM · Hide· #5
    Also, many of the images are embedded from around the 'net, and not located on my server. So, to further extend my wish list for RIE, I would like embedded images to be shown by RIE, too.

    Hmm RIE will create a thumbnail file for each images you have on the article. And you can't do that if the image is not located on your server.
    To make it able to download remote images before creating thumbnail will add additional process/load to the module itself and opening the door for some security issue possibilities
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
Your Response
Please login first in order for you to submit comments