Whatsapp Mutliagent Recaptcha not working

Good day, I just downloaded and activated the module; thank you. All seems well, apart from the offline email and the Recaptcha.

I have entered the V2 ReCaptcha key & secret key. When sending the email, I'm getting the I'm not a robot green tick and occasionally the pictures to click (not every time). This, too, results in the tick. However, when clicking send, a message comes up saying, 'Please click on the I'm not a robot checkbox', so I presume the module is not reading/understanding that the Recaptcha has been ticked.

Could you please advise on how to get around this?

Thank you so much for your attention and response.
Resolved
The discussion has been resolved.

Accepted Answer

10 responses Add Yours
     
  • Replied by admin on Friday, June 04 2021, 01:28 PM · Hide· #1
    Hi Can you tell me your website url so I can test it?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Friday, June 04 2021, 01:55 PM · Hide· #2
    Hmm, are you sure you have entered the correct recaptcha keys?
    https://www.dropbox.com/s%2Fcg3kg1fuwgifdwb%2Fmonosnap%25202021-06-04%252020-54-56.png?raw=1
    • kemble - 2 weeks ago
      Yes. ReCAPTCHA V2 'I'm not a robot checkbox' as above. Have also tried the Invisible just to be on the safe side (no changes) and V3 but it rejects the V3 with a note to the owner that an incorrect key entered.
    • admin - 2 weeks ago
      Is the domain name entered properly too?
    • admin - 2 weeks ago
      Anyway, can you try the demo page https://demo.templateplazza.com/joomla/index.php/email-form-fallback . Does the re-captcha work properly on your side?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kemble on Friday, June 04 2021, 03:30 PM · Hide· #3
    Thank you for the speedy response I have tripled checked the details:

    The domain is entered correctly (plus sub-domains) and Re-captcha is working successfully on our contact us form on another page.

    I can also confirm that it works for me successfully on your fallback page so beyond that I'm not sure if I'm just doing something wrong. (Whatsapp online all works perfectly) so any further advice is very much appreciated.
  •  
  • Replied by admin on Friday, June 04 2021, 03:36 PM · Hide· #4
    Re-captcha is working successfully on our contact us form on another page.
    Can you point me to the page where the contact us form work properly? So I can compare them
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kemble on Friday, June 04 2021, 04:13 PM · Hide· #5
    Hi There,

    I have just tried it from the UK and it works for me.
    Also it works from Turkey.
    I have attached the actual part as this is not super clear. When clicked upon opens up and shows the recaptur.
    BTW we are on Joomla 3.9.27 (the latest just incase)
    Keith

    Attachments:

  •  
  • Replied by admin on Saturday, June 05 2021, 11:23 AM · Hide· #6
    Ah ok sorry. I misunderstood you. The contact form does work properly. Can you tell me what extensions you have on your website so I can try to replicate it on my local computer to debug the problem?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kemble on Saturday, June 05 2021, 01:59 PM · Hide· #7
    My apologies for lateness in replying - Got BSOD from Nvidia update this morning. Back up and running now.
    Would it be easier for me to grant temporary backend access ?

    If so email me and I will reply with usual.

    Keith
  •  
  • Replied by admin on Saturday, June 05 2021, 03:36 PM · Hide· #8
    Would it be easier for me to grant temporary backend access ?
    Yes, sure. You can share it in the Your Site Details tab below. Only you and support staffs who are able to see it.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kemble on Saturday, June 05 2021, 04:28 PM · Hide· #9
    as requested, see details
  •  
  •  
    Replied by kemble on Sunday, June 06 2021, 07:43 AM · Hide· #10
    HI Admin,
    I have actioned the PHP options on "allow_url_fopen" to enable and the offline works.

    May I say thank you for your quick support and patience. Greatly appreciated.
    Thanks again. Great support
    • admin - 2 weeks ago
      Not a problem at all. Glad could help ;)
Your Response
Please login first in order for you to submit comments