Quote

We're also available for Custom Joomla Development

Hire us now

message

Hi, during the design of an administrative page, this message appears:

Notice: Trying to get property 'id' of non-object in /home/goinfor4/public_html/eneastudiolegale/modules/mod_whatsapp_agent/tmpl/default.php on line 122
He needs help? let's talk about
1

But the front end module works correctly.

Could you tell me if it's solvable?
Thanks

Attachments:

Resolved
The discussion has been resolved.
11 responses Add Yours
       
  • Replied by superdiogene on Tuesday, September 17 2019, 04:23 PM · Hide· #1
    I apologize for the post. I solved I had opened another instance of the module on the other monitor that's why it gave me that message.
    Mariano
  •  
  • Replied by admin on Wednesday, September 18 2019, 12:11 AM · Hide· #2
    Ah ok, thanks for let me know ;) That error message should not be appear in the administrator page
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by superdiogene on Wednesday, September 18 2019, 10:18 AM · Hide· #3
    I apologize but the problem has recurred and persists.

    Attachments:

  •  
  • Replied by admin on Wednesday, September 18 2019, 12:28 PM · Hide· #4
    Strange, Is the error appear in the frontend or backend (administrator page)?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by superdiogene on Wednesday, September 18 2019, 01:39 PM · Hide· #5
    backend
  •  
  • Replied by admin on Wednesday, September 18 2019, 01:58 PM · Hide· #6
    Strange, the error message should not appear in the backend, as it's referring to frontend module.
    Anyway could you tell me what joomla and php version do you use?
    Is it possible to get a temporary access to your administrator page? If it's possible you can add them in the Your Site Details tabs below. Only support team will be able to see it.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by superdiogene on Wednesday, September 18 2019, 02:38 PM · Hide· #7
    The Joomla! Version 3.9.11
    The PHP version 7.3.9
    I have communicated the access data.

    To view the problem:
    1) Quix menu
    2) Pages
    3) click on Home-enea
    4) after the slider find the message

    Thanks
    Mariano
  •  
  • Replied by admin on Wednesday, September 18 2019, 11:51 PM · Hide· #8
    Ok I'll have a look on it now
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Thursday, September 19 2019, 12:41 AM · Hide· #9
    I've made a small fix for that.
    I moved the line 122 :
    $menu = $app->getMenu()->getActive()->id;

    to line 153 , before the code :
    if($item->greeting_menu_item == $menu) {

    The problem is because the module is searching the menu id of current page (for greeting override based on menu id) but I don't know why it's not available in quix.

    Please try it, and let me know if the problem persist
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by superdiogene on Thursday, September 19 2019, 08:10 AM · Hide· #10
    Thanks for your assistance, everything seems to be working fine and the message is no longer displayed.
    If you still have information, I'll let you know.
    good job
    Mariano
  •  
  •  
    Replied by admin on Thursday, September 19 2019, 09:47 AM · Hide· #11
    Np, glad could help ;)
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
Your Response
Please login first in order for you to submit comments