luiscar on Monday, September 20 2021, 11:41 AM

Module Related Items doesn't generate thumbnails

Hello,

I'v purchased Module Related Items yesterday. After installation and settings, I can't see the thumbnails. I'm working over a fresh Joomla 4 installation. I've checked the permissions, change the thumbnail size several times, empty the /thumbnails/mod_relateditems_xtd folder, refresh the browser, etcetera. In general, I did all your support pages say I must do. I can provide you superadmin access, but since I want to keep track of any change, I'd need to know exactly what you do there. In other words, if you fix the problem, I want to know how you did it.
22 responses Add Yours
       
  • Replied by admin on Monday, September 20 2021, 02:58 PM · Hide· #1
    Hi, There's some changes are made between Joomla 4 RC version with the prodution one.
    Can you try to change these lines ? :

    // Find Article's Image
    			if (!empty($images->image_intro) ) { 
    				$orig_image = $images->image_intro;
    			} elseif (empty($images->image_intro) && !empty($images->image_fulltext) ) { 
    				$orig_image = $images->image_fulltext;

    with

    // Find Article's Image
    			if (!empty($images->image_intro) ) { 
    				// J4 - remove strings after # character image_intro
    				$orig_image = strstr($images->image_intro, '#', true);
    			} elseif (empty($images->image_intro) && !empty($images->image_fulltext) ) { 
    				// J4 - remove strings after # character image_fulltext
    				$orig_image = strstr($images->image_fulltext, '#', true);



    in both of these files :
    modules/mod_relateditems_xtd/Helper/RelatedItemsXtdHelperMetaKey.php
    modules/mod_relateditems_xtd/Helper/RelatedItemsXtdHelperTag.php
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by luiscar on Monday, September 20 2021, 04:22 PM · Hide· #2
    Hi,

    Thank you for your help!

    I replaced the lines in both files, but images still not shown.

    Please, take a look at the screen capture attached. Maybe I missed something.

    Thanks again,

    Luis
  •  
  • Replied by luiscar on Monday, September 20 2021, 04:24 PM · Hide· #3
    And another thing: there's no files in images/thumbnails/mod_relateditems_xtd directory, except an empty index.html.
  •  
  • Replied by admin on Monday, September 20 2021, 11:22 PM · Hide· #4
    Ok I will look into this more thoroughly and get back to you soon
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by luiscar on Tuesday, September 21 2021, 06:30 AM · Hide· #5
    Thank you for your help!
  •  
  • Replied by admin on Tuesday, September 21 2021, 08:47 AM · Hide· #6
    Hi luiscar, I have tried it on my localhost but still unable to replicate the issue. Thumbnails are generated properly. Are you sure you have modified the files above?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by luiscar on Tuesday, September 21 2021, 08:57 AM · Hide· #7
    Yes, I'm positive. The screenshot I attached earlier shows the new lines.
  •  
  • Replied by admin on Tuesday, September 21 2021, 08:59 AM · Hide· #8
    Is it possible for me to access the administrator page temporarily so I can try to install the fix?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by luiscar on Tuesday, September 21 2021, 09:26 AM · Hide· #9
    Yes. I sent temporary superuser name and pwd when I opened this question. Please don't forget to tell me what you do in the backend. Just to keep control. Thank you!
  •  
  • Replied by admin on Tuesday, September 21 2021, 11:57 AM · Hide· #10
    Yes, but it doesn’t work because your administrator page is protected by .htaccess ;)
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by luiscar on Tuesday, September 21 2021, 12:59 PM · Hide· #11
    Ok. Let me see...
  •  
  • Replied by luiscar on Tuesday, September 21 2021, 01:13 PM · Hide· #12
    I've replaced .htaccess. Please, try now.

    Thank you!
  •  
  • Replied by admin on Tuesday, September 21 2021, 01:27 PM · Hide· #13
    ok let me try it
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Tuesday, September 21 2021, 01:33 PM · Hide· #14
    I tried to install the module but I think there's a permission problem with your website?
    https://www.dropbox.com/s%2F9y552h6kqkpo52b%2Fextensions%2520install%2520-%2520noticias%2520iruya.com%2520-%2520salta%2520-%2520administration%25202021-09-21%252020-31-10.png?raw=1
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by luiscar on Tuesday, September 21 2021, 01:49 PM · Hide· #15
    Let me check!
  •  
  • Replied by luiscar on Tuesday, September 21 2021, 01:51 PM · Hide· #16
    Please, try now, and let me know. Thanks!
  •  
  • Replied by admin on Tuesday, September 21 2021, 02:21 PM · Hide· #17
    Hi, I think the changes you made before was not properly made. I have uploaded the file the same fix above and it looks like the thumbnail is now generated properly? Can you check it please? Don't forget to hard-refresh your browser.
    https://www.dropbox.com/s%2Fnw9ogifhcdyqyao%2Fde%2520la%2520guerra%2520de%2520zapa%2520a%2520la%2520crisis%2520de%2520gobernabilidad%2520-%2520noticias%2520iruya.com%2520-%2520salta%25202021-09-21%252021-16-35.png?raw=1
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by luiscar on Tuesday, September 21 2021, 03:49 PM · Hide· #18
    Well, I can see the thumbnails now. Thank you very much. The changes were made just as you suggested, and they didn't work. Please, check the last screenshot and tell me if there's something wrong in those lines. It would be a great help to me. Thanks again!
  •  
  • Replied by admin on Tuesday, September 21 2021, 10:54 PM · Hide· #19
    You're most welcome luiscar ;) Glad the problem finally solved.
    Please, check the last screenshot and tell me if there's something wrong in those lines.

    There's is nothing wrong in those lines, maybe it was just a server cache matter so the changes didn't apply immediately
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Tuesday, September 21 2021, 10:59 PM · Hide· #20
    Oh, one thing. I created a template override for related items module in your template for testing purpose. You can delete that folder, it's located under html folder in your active template
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Wednesday, September 22 2021, 10:50 PM · Hide· #21
    Hi luiscar, we just released an update for related extended module with some bugfixes for joomla 4. You can download the update from https://www.templateplazza.com/your-download
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  •  
    Replied by luiscar on Thursday, September 23 2021, 09:17 AM · Hide· #22
    Thank you very much for your help!! I will download the update right away.

    Kind regards,

    Luis
Your Response
Please login first in order for you to submit comments