Related Items Extended error After installation

1.After the installation I get the specific error

0
NO VALID IMAGE WAS LOADED.

When I turn off the module everything works fine

https://adapokrites.gr/adapokrites/diethneis-eidiseis/bil-geits-eyporoi-trone-synthetiko-kreas-synithisoun-geysi

https://adapokrites.gr/adapokrites/diethneis-eidiseis/vinteo-sok-me-apopeira-viasmoy-sto-metro-tou-manxatan

2.I would also like to ask you if the extension it is possible not to create images.
Specifically the extension to use the already existing images of the articles.
This is the case with the other extension
Resolved
The discussion has been resolved.
31 responses Add Yours
       
  • Replied by admin on Wednesday, February 24 2021, 01:53 AM · Hide· #1
    Hmm really strange, Let me check on your website. Will back to you soon.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Wednesday, February 24 2021, 01:56 AM · Hide· #2
    Anyway, how did you add any image in an article? I found the module works properly in this article https://adapokrites.gr/adapokrites/paraksena-video/tromaktikes-prosgeioseis-aeroskafon-video
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kamaretsos on Wednesday, February 24 2021, 02:34 AM · Hide· #3
    I do not know exactly what is happening! It works on most articles. But it turns out the same problem that I sent you in many articles.
    When I turn off the tool everything works normally.
  •  
  • Replied by admin on Wednesday, February 24 2021, 02:38 AM · Hide· #4
    Ok, let me check it deeply on your website
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kamaretsos on Wednesday, February 24 2021, 02:49 AM · Hide· #5
    All articles work with a 700x400 image.
    The image is normally integrated by joomla content

    Observation!

    All articles that play on the website are after the first 300.

    The first 300 are integrated with feeds

    I will turn them off to see if this is to blame

    Attachments:

  •  
  • Replied by admin on Wednesday, February 24 2021, 03:04 AM · Hide· #6
    Ah ..
    The first 300 are integrated with feeds
    Are they using external images?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kamaretsos on Wednesday, February 24 2021, 03:11 AM · Hide· #7
    yes!

    You have done an excellent job both in the design and in the articles that appear in the results!!!!
  •  
  • Replied by admin on Wednesday, February 24 2021, 03:14 AM · Hide· #8
    yes!
    Can you tell me an example article that is using the external image?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kamaretsos on Wednesday, February 24 2021, 03:52 AM · Hide· #9
    the problem is that for some reason it adds to the image address the category address (/diethneis-eidiseis/)

    If you disable the extension the image is displayed normally

    To see where the error is you can reproduce the following

    https://adapokrites.gr/adapokrites/diethneis-eidiseis/tragodia-sti-gallia-prosfygas-feretai-na-maxairose-ton-proistameno-kentrou-ypodoxis


    the mistake
    https://adapokrites.gr/adapokrites/diethneis-eidiseis/images/2021/02/12/gallia_maxairoma.jpg

    the right
    https://adapokrites.gr/adapokrites/images/2021/02/12/gallia_maxairoma.jpg

    Attachments:

  •  
  • Replied by kamaretsos on Wednesday, February 24 2021, 05:38 AM · Hide· #10
    I temporarily disable the extension because it causes me problems to editing the articles.

    You can activate it whenever you want for the tests!!!
  •  
  • Replied by admin on Wednesday, February 24 2021, 05:54 AM · Hide· #11
    I temporarily disable the extension because it causes me problems to editing the articles.

    Do you edit articles in the frontend?

    You can activate it whenever you want for the tests!!!
    Ok. Thanks
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kamaretsos on Wednesday, February 24 2021, 12:33 PM · Hide· #12
    you have identified what is causing the problem?
    do you think we will find a solution to the problem?
    Thanks!!!
  •  
  • Replied by admin on Wednesday, February 24 2021, 02:55 PM · Hide· #13
    I'm still trying to find a solution. I'll be back to you soon
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kamaretsos on Wednesday, February 24 2021, 03:17 PM · Hide· #14
    Thanks!!!
  •  
  • Replied by admin on Wednesday, February 24 2021, 03:42 PM · Hide· #15
    Can you check is there anything wrong with this article :
    https://adapokrites.gr/adapokrites/ksenos-typos/dw-nees-prosfygikes-odoi-pros-tin-evropi

    If I tried to unpublish that article, then the error in this page is gone :
    https://adapokrites.gr/adapokrites/diethneis-eidiseis/tragodia-sti-gallia-prosfygas-feretai-na-maxairose-ton-proistameno-kentrou-ypodoxis
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kamaretsos on Wednesday, February 24 2021, 05:40 PM · Hide· #16
    The first article ( https://adapokrites.gr/adapokrites/ksenos-typos/dw-nees-prosfygikes-odoi-pros-tin-evropi ) was missing, read more in the first paragraph of the article
    I added it and activated the article.

    Article 2 ( https://adapokrites.gr/adapokrites/diethneis-eidiseis/tragodia-sti-gallia-prosfygas-feretai-na-maxairose-ton-proistameno-kentrou-ypodoxis ) plays normally.

    But there is still a problem in other articles.
    For example
    https://adapokrites.gr/adapokrites/diethneis-eidiseis/gallia-epithesi-se-elliniki-ekklisia-sti-lyon

    https://adapokrites.gr/adapokrites/diethneis-eidiseis/oi-filippines-etoimazontai-gia-to-sarotiko-perasma-tou-tyfona-goni

    https://adapokrites.gr/adapokrites/diethneis-eidiseis/to-thanato-dyo-paidion-se-ekriksi-narkis-stin-tripoli-kataggellei-i-unicef

    https://adapokrites.gr/adapokrites/diethneis-eidiseis/ispania-sygkroyseis-metaksy-astynomikon-kai-diadiloton-varkeloni

    and many more...


    NOTE
    There are 30,000 articles of which about 5,000 do not have photos. (unfortunately lost in the migration process)
    Also columnists often forget to add read more.:(
    But I do not understand that such a thing can create such a serious problem in the operation of the extension.

    With the same default existing extension does not create any problem in the Website,but
    It is simply very poorly made in the results it presents. SHOWS IRRELEVANT ARTICLES

    I will be very happy if you find the solution to the problem so I can use your extension
  •  
  • Replied by admin on Thursday, February 25 2021, 02:30 AM · Hide· #17
    There are 30,000 articles of which about 5,000 do not have photos. (unfortunately lost in the migration process)
    This could be the reason, because when the error is coming from the thumbnail generation process, that unable to find the image. But it is strange that you said that adding the read more fixed the problem because I don't think it is related with 'read more' in the content.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Thursday, February 25 2021, 02:59 AM · Hide· #18
    Well I just found out, that it's not adding the readmore that will fix it, but simply re-saving the article will fix it. I just re-saved this article (without adding a new 'read more') : https://adapokrites.gr/adapokrites/perivallon/wwf-misos-aionas-katastrofis-gia-tin-agria-zoi and then error on this page is gone :
    But there is still a problem in other articles.
    For example
    https://adapokrites.gr/adapokrites/diethneis-eidiseis/gallia-epithesi-se-elliniki-ekklisia-sti-lyon
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Thursday, February 25 2021, 03:55 AM · Hide· #19
    I have made some changes to the module helper. Can you check again whether the issue still exist or not?

    I have checked all of these articles and all of them are working properly :
    But there is still a problem in other articles.
    For example
    https://adapokrites.gr/adapokrites/diethneis-eidiseis/gallia-epithesi-se-elliniki-ekklisia-sti-lyon

    https://adapokrites.gr/adapokrites/diethneis-eidiseis/oi-filippines-etoimazontai-gia-to-sarotiko-perasma-tou-tyfona-goni

    https://adapokrites.gr/adapokrites/diethneis-eidiseis/to-thanato-dyo-paidion-se-ekriksi-narkis-stin-tripoli-kataggellei-i-unicef

    https://adapokrites.gr/adapokrites/diethneis-eidiseis/ispania-sygkroyseis-metaksy-astynomikon-kai-diadiloton-varkeloni

    and many more...
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kamaretsos on Thursday, February 25 2021, 08:09 AM · Hide· #20
    From what I understood if I edit the article the mistake goes away. Correctly;

    There are still mistakes. What is happening is inexplicable. I understand!
    https://adapokrites.gr/adapokrites/diethneis-eidiseis/ollandia-anakoinothike-proti-egxoria-molynsi-apo-io-dytikoy-neilou

    Anyway, thank you for all the effort and help you offered me!!!

    I would like to ask you if the thumbnails created by the extension are deleted and after how long?
  •  
  • Replied by admin on Thursday, February 25 2021, 08:36 AM · Hide· #21
    There are still mistakes. What is happening is inexplicable. I understand!
    https://adapokrites.gr/adapokrites/diethneis-eidiseis/ollandia-anakoinothike-proti-egxoria-molynsi-apo-io-dytikoy-neilou
    Ahh .. I even already added a handler to handle non-existent(missing) images, but I don't know why this still happening. What makes it strange is that this can be fixed by re-saving the specific related article.

    Anyway how did the 5,000 lost photos are inserted to the article? Is it inserted to intro image and fulltext image?

    I would like to ask you if the thumbnails created by the extension are deleted and after how long?

    The thumbnail images are never deleted for performance reason. The module generates the thumbnail only once, then later the module will call the existing thumbnail file directly without trying to re-generate the thumbnail, because generating thumbnail can take a significant server resource consumption (depends on the server ram and cpu), especially when you have a big 4K photos in your article.
    But those thumbnails can be manually deleted by deleting image files in the folder : ../images/thumbnails/mod_relateditems_xtd Once the thumbnails are deleted, the module will regenerate a new ones when the module is loaded in the frontpage.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kamaretsos on Friday, February 26 2021, 08:57 AM · Hide· #22
    The 5,000 missing photos of the articles have not included thumbnails and full text images. Unfortunately. We are trying to get new ones again, but it takes time.


    I would also suggest that in an upcoming upgrade there is an option so that the extension can use the existing photos of the articles.

    Of course, only websites with thousands of articles need this.
    Imagine a website with 300,000 articles, how much space the thumbnails take up on the server.

    For example
    To save space on the server, we use a 700 x 400 photo that appears as a thumbnail and an article photo.

    In this way our website with 30,000 articles occupies only 1 giga on the server

    Correspondingly, I know websites that with half articles occupy more than 10 giga in the server

    This is an issue that no cms ( joomla, wordpress) has taken seriously.



    Thank you again for the help you offered me !!!!
  •  
  • Replied by admin on Sunday, February 28 2021, 12:03 AM · Hide· #23
    Of course, only websites with thousands of articles need this.
    Imagine a website with 300,000 articles, how much space the thumbnails take up on the server.
    I see, although the generated thumbnails are only about 5-40kb in size, I can understand that it will take a lot of storage when you have 300.000 articles.
    I would also suggest that in an upcoming upgrade there is an option so that the extension can use the existing photos of the articles.
    You can do that easily via template override actually. Basically you just need to comment this line (I'm assuming you're using carousel_xt) :
    $thumb_img = ModRelatedItemsXtdHelper::getThumbnail($params, $item->id, $item->images, $item->title,$item->introtext,$module->id);
    and change it with :
    $images = json_decode($item->images);
                    // Find Article's Image
                    if (!empty($images->image_intro) ) { 
                        $thumb_image = $images->image_intro;
                    } elseif (empty($images->image_intro) && !empty($images->image_fulltext) ) { 
                        $thumb_image = $images->image_fulltext;
                    } else {
                        // Find first image in the article
                        $html = $item->introtext;
                        $pattern = '/src="/([^"]+)"/';
    
                        if ( preg_match($pattern, $html, $match) ) {
                            $thumb_image = $match[1];
                        } else {
                            $thumb_image = "";
                        }
                    }


    and then change the code
    <div class="mfp_overlay_bg" style="background:url(<?php echo $thumb_img[1]; ?> ) no-repeat;"></div>

    with this one
    <div class="mfp_overlay_bg" style="background: url('/<?php echo $thumb_image; ?> ') no-repeat;"></div>
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kamaretsos on Monday, March 01 2021, 03:01 PM · Hide· #24
    First of all, thank you once again for your interest !!!
    It's very pleasing new that the photos of the articles can be used.

    The problem is that I do not understand exactly what I have to do and I am afraid to make the changes.

    You would honestly help me a lot, if you have the time, to make the changes.

    I know I ask you a lot !!!!

    Even if you can not, I am very happy with our cooperation

    Thank you !!!
  •  
  • Replied by admin on Tuesday, March 02 2021, 02:56 PM · Hide· #25
    Hi kamaretsos, Sorry for not replying sooner. I was thinking that I have replied to your previous reply.
    Yes I can do that. Please confirm, once you confirm it I will enter your administrator page to make the changes
    • admin - more than a month ago
      Please note that when loading the original image as thumbnail, there is a possibility that the page load will slow down a bit because all the images those are loaded are the original images which may have a large size.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kamaretsos on Tuesday, March 02 2021, 03:20 PM · Hide· #26
    Thank very very very much!!!!:D
    You have my permission to make the changes.You have the codes. The user has full rights!
    If you need anything let me know.
  •  
  • Replied by admin on Tuesday, March 02 2021, 03:40 PM · Hide· #27
    Done. Please have a look on the video below to see what I've changed ;)
    Update :
    Sorry I have to remove the video, because it accidentally exposed the username and password in the video. Please change the password for user templateplazza immediately ;)
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kamaretsos on Tuesday, March 02 2021, 03:56 PM · Hide· #28
    I changed the codes. If you can, send me the video to the email This email address is being protected from spambots. You need JavaScript enabled to view it..
    Can I use any canvas with the same settings?

    You are amazing professionals and.....characters

    Thank you !!!!!!!!!!!!!
  •  
  • Replied by admin on Tuesday, March 02 2021, 03:59 PM · Hide· #29
    If you can, send me the video to the email This email address is being protected from spambots. You need JavaScript enabled to view it..
    Done. Please check your email.

    Can I use any canvas with the same settings?
    basically yes

    Np glad could help ;)
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by kamaretsos on Tuesday, March 02 2021, 04:04 PM · Hide· #30
    I really have no words to thank you!
    Both your help and the extension were very important to me!!!:D:D:D:D:D
  •  
  •  
    Replied by admin on Wednesday, March 03 2021, 11:09 PM · Hide· #31
    No problem at all. Glad could help ;)
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
Your Response
Please login first in order for you to submit comments