Quote

We're also available for Custom Joomla Development

Hire us now

Google Map isn't displaying

ContactMap

I am confident that the module is configured correctly and that the longitude and latitude are correct but the map is just not displaying

Can you please help?

Thanks

Attachments:

Resolved
The discussion has been resolved.
19 responses Add Yours
       
  • Replied by discstop on Saturday, January 30 2016, 05:47 PM · Hide· #1
    also my page is displaying
    Error loading component: com_contactmap, Component not found, however it is displaying the form, extra but no map

    When I bought this it said it was joomla 3 compliant... it uploaded fine, it enabled fine. it added to a module fine and all of the fields were filled in fine and published. Why would this happen
  •  
  • Replied by admin on Monday, February 01 2016, 02:53 AM · Hide· #2
    Hi discstop, sorry for delay in responding due to weekend offline.
    Btw, Can you let me know the URL of your site so I can take a look?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by discstop on Monday, February 01 2016, 06:40 AM · Hide· #3
    www.new.fashionrider.com/contact
  •  
  • Replied by admin on Monday, February 01 2016, 03:12 PM · Hide· #4
    Hi, I see that your website loads multiple jquery libs, and I see few js errors in the console. Can you try to install jquery easy plugin to solve the jquery confliction issue?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by discstop on Tuesday, February 02 2016, 01:34 PM · Hide· #5
    I tried this and the report I got was:

    jQuery is loaded by the template
    re-ordered header libraries
    removed 1 jquery-noconflict.js script(s)
    removed jQuery library /media/jui/js/jquery.min.js
    removed jQuery library templates/templatetest/js/jquery-2.1.3.min.js
    removed jQuery library http://code.jquery.com/jquery-latest.pack.js
    removed jQuery library http://code.jquery.com/jquery-latest.pack.js
    added the jQuery library http://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js
    removed 1 Migrate script(s)
    added the script /plugins/system/jqueryeasy/jquerynoconflict.js
    removed 6 empty script tag(s)

    The map still did not display - I genuinely cannot find the conflict - can you help
  •  
  • Replied by discstop on Tuesday, February 02 2016, 02:33 PM · Hide· #6
    I have attached a capture of the firebug errors when loading the http://new.fashionrider.com/contact page.... hope this will help you

    Attachments:

  •  
  • Replied by admin on Wednesday, February 03 2016, 02:35 AM · Hide· #7
    Hmm, there are still multiple jquery loads on your website. Even one is loaded in the body

    Can you try to switch the template temporarily to protostar, to check whether the issue something related to template or extensions?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by discstop on Wednesday, February 03 2016, 08:36 AM · Hide· #8
    Hi

    I had already tried this but just so that you can see I have used the protostar template with nothing on the page but the contactmap module. http://new.fashionrider.com/contact

    Any ideas?
    Thanks
  •  
  • Replied by admin on Wednesday, February 03 2016, 09:47 AM · Hide· #9
    Can you try to disable the scroll to top plugin and let me know the result?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by discstop on Wednesday, February 03 2016, 09:56 AM · Hide· #10
    I will do this to humour you but if you go through firebug errors there are 2 with your component. As I downloaded the version of 29th Jan 2016 would you please consider that you have introduced a bug yourself. I feel that you are deflecting all the problems to my site and not considering that the fault is with your code.
  •  
  • Replied by discstop on Wednesday, February 03 2016, 11:03 AM · Hide· #11
    I can confirm that this is not a 'scroll to top' plugin - I do not have one... it is clearly part of the standard protostar template
  •  
  • Replied by admin on Wednesday, February 03 2016, 11:11 AM · Hide· #12
    Yes there are two notices/messages in the console, one for the uncaught not a function error with section1map (that should not be happened) and one for Google Map api warning (that should be OK). But before those messages, there's one error that is referring to your scroll to top plugin.

    https://www.dropbox.com/s/hwn5nrkg8yx9hu8/4gpbs.jpg?raw=1
    I feel that you are deflecting all the problems to my site and not considering that the fault is with your code.
    I'm not deflacting the problem, I'm trying to find what elements that is potentially conflicted with the module javascript because I'm unable to replicate the problem at my end. If disabling the scrolltotop still doesn;t solve the problem then I will ask you to give me a temporary access to your site and ftp so I can check the problem by myself
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Wednesday, February 03 2016, 11:14 AM · Hide· #13
    I can confirm that this is not a 'scroll to top' plugin - I do not have one... it is clearly part of the standard protostar template

    ok, then can you provide temporary access to your website so I can check the problem by myself? If it's possible you can enter the details using the "You Site Details" tab below. Only support team who are able to see that.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by discstop on Wednesday, February 03 2016, 11:26 AM · Hide· #14
    I have attached the details of the errors showing in firebug BOTH are related to your component.
    I am not getting the 'scroll to top' error that you state in any console or with ANY different template.

    Please fix the bugs in your code. I am not happy to share admin access when you are not willing to accept that you have 2 x issues in your own code. If you fix those first and it is not that then I will happily share admin. I have proven that you have the problems.

    Attachments:

  •  
  • Replied by admin on Wednesday, February 03 2016, 11:59 AM · Hide· #15
    then how can't I fix the problem if I can see and replicate the problem at my end. Please see this video
    https://www.dropbox.com/s/rgz8zzcsn4mcjhw/contactmappcasst.mp4?raw=1

    regarding the scroll to top script, you can see that at the end of movie, you website load mootools and scrolltotop js

    anyway. maybe you can share what setting you have on the module so I can try to replicate here
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by discstop on Wednesday, February 03 2016, 12:33 PM · Hide· #16
    The module has been removed and the map does still not appear
  •  
  • Replied by admin on Thursday, February 04 2016, 03:11 AM · Hide· #17
    Hi, I've made some code changes to the module, please try to use this and let me know whether it's working or not
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by discstop on Thursday, February 04 2016, 09:16 AM · Hide· #18
    Its working perfectly now - thank you very much for your support and patience :D
  •  
  •  
    Replied by admin on Thursday, February 04 2016, 10:29 AM · Hide· #19
    Ah nice. Glad it's finaly solved. I will make this version available as an update ;)
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
Your Response
Please login first in order for you to submit comments