mod_minifrontpagepro_j3 error

Hi, I post this also in my Free tread.
After installing mod_minifrontpagepro_j3 I got an white front- page. - 0: The image does not exist -
On the same domain. The mod_minifrontpage_J3 is working fine out of the box.
I choose my own overall header picture and indeed in the thumbnails folder there is one generated image.
What went wrong?

I installed on Joomla 4.0.3 - mod_minifrontpagepro_j4 without any problem.
Summary:
On the same domain:
The free version is working fine, as expexted.
The pro version gives a white page.
I also removed the mod_minifrontpage_J3 for avoid a possible conflict.
Regards,
milian

Attachments:

31 responses Add Yours
       
  • Replied by admin on Friday, October 01 2021, 03:22 PM · Hide· #1
    Hi millian,
    I got 403 error when trying to access the administrator page. Can you check it please?
    https://www.dropbox.com/s%2Fu3yzx5fpfy574ip%2F403%2520forbidden%25202021-10-01%252022-21-34.png?raw=1
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by milian on Friday, October 01 2021, 05:03 PM · Hide· #2
    Sorry. You have access now.
    Admin was protected with an IP limitation.
    Hoe you find it.
    Regards
    ,Milian
  •  
  • Replied by milian on Friday, October 01 2021, 05:07 PM · Hide· #3
    I filled in some site details for you.
  •  
  • Replied by admin on Friday, October 01 2021, 11:07 PM · Hide· #4
    Hi millian, It's strange. When I tried to change the category to Archief 2016 then the module is working properly. I think this is something related to external image inside the article, because minifrontpage free version doesn't process image from external site.
    I need to make some test in the article but it will need to modify the content. Can I make some test by modifying this article's content ? : Verhuizing en de winkel (https://ja30-bp.maxfolmer.nl/administrator/index.php?option=com_content&view=article&layout=edit&id=636)
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by milian on Saturday, October 02 2021, 06:48 AM · Hide· #5
    Yes, you can make any modification you need.
    This is my test site for the real site when everything is working fine, i install it on the production site:)
    regards, Max
  •  
  • Replied by milian on Saturday, October 02 2021, 07:04 AM · Hide· #6
    I removed this line in: Verhuizing en de winkel
    <p><img class="spict" alt="" src="/ja30-acy/index.php?option=com_acymailing&amp;ctrl=statistics&amp;mailid=130&amp;subid=11" border="0" height="1" width="50" /></p>
  •  
  • Replied by milian on Saturday, October 02 2021, 07:07 AM · Hide· #7
    Now its working! The link was going to nowhere (ja30-acy) because this website is a copy on another server.
    Strange that the mod_minifrontpage_J3 has not that problem of blokking. (mod_minifrontpage_J3 ignores that line.
  •  
  • Replied by milian on Saturday, October 02 2021, 07:13 AM · Hide· #8
    I was wrong. You set another Category I thought it was working.... But probably you are close..
  •  
  • Replied by milian on Saturday, October 02 2021, 07:29 AM · Hide· #9
    I installed mod_minifrontpage_J3 on another demo server with the same content. If I disable all the Categories, I got the same error.
    -0: The image does not exist -
    Then I set one article ON, the same erre]or exists. It seems that it lies outsiide the content so far as I have tested.
  •  
  • Replied by milian on Saturday, October 02 2021, 08:11 AM · Hide· #10
    For the record: With another category reader the "Nieuwsbrieven archief 2021" is served ok.

    https://ja30-bp.maxfolmer.nl/nieuwsbrieven/nieuwsbrieven-archief-2021-latest

    Of cource you can install a modified mod_minifrontpagepro_j3 if needed.
  •  
  • Replied by milian on Saturday, October 02 2021, 11:24 AM · Hide· #11
    Hi,
    I have mod_minifrontpagepro_j3 working.

    See: Refeernce link..

    What was/is the problem.

    When I moving/copying a website to another DIR or another domain with AKEEBA.
    /ROOT website/ to /ja30-bp/ folder.

    I changes <img src="/images/..) to <img src="/images/..)
    Now it is working.

    The mod_minifrontpage_J3 has none of these errors.
    Therefore I purchased mod_minifrontpagepro_j3

    And here starts te white page error(s).

    I changes <img src="/images/..) to <img src="/images/..)


    But the free mod_minifrontpage_J3 was working fine out of the box without any modifiing.

    -----
    I hope on an update with the same flexability on this issue as the mod_minifrontpage_J3

    With mod_minifrontpagepro_j3 it is not possible to move the website to another domain (with AKEEEBA)
    and got it working. This can only be done with mod_minifrontpage_J3.

    I know it is the way I paste newsletters from ACY-mailing in an existing website but as I mentioned
    the free mod_minifrontpage_J3 has no problems at all.
    Regards,
    MIlian
  •  
  • Replied by admin on Saturday, October 02 2021, 12:11 PM · Hide· #12
    Hi Milian,
    Hmm really strange. Minifrontpagepro should have a better/complex codebase than minifrontpage. Let me check on it.
    I changes <img src="/images/..) to <img src="/images/..)
    Anway what is the difference of between of those?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by milian on Saturday, October 02 2021, 12:21 PM · Hide· #13
    Sorry. Must be:
    <img src="/images/..)
    • admin - 3 weeks ago
      Still, what is the difference? :)
  •  
  • Replied by milian on Saturday, October 02 2021, 12:56 PM · Hide· #14
    I removed the foreward slash ( / ) for:
    <img width="748" height="185" style="vertical-align: top;" src="/images/headers/nieuwsbrief-header-db-2021-website.jpg" alt="banner 540 zomer" />
    I did it on all the 2021 articles and so I got it working.
  •  
  • Replied by admin on Saturday, October 02 2021, 01:14 PM · Hide· #15
    Ah I see. Anyway, I'm now unable to access the Media manager. It said that the folder is empty and invalid fm_request. Can you check it?
    https://www.dropbox.com/s%2Fz6u0g6djm2ltk4u%2Fjmedia%2520-%2520boekhandel%2520praamstra%2520-%2520administration%25202021-10-02%252020-13-42.png?raw=1
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Saturday, October 02 2021, 01:44 PM · Hide· #16
    Ok, I can replicate the issue. Working on it. The issue is also because of that you are using JCE that is not automatically replace the foreward slash as TinyMCE does
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by milian on Saturday, October 02 2021, 02:15 PM · Hide· #17
    I see that the whole image folder is empty now.
    Do I need to replace the website. Or are you testing?
  •  
  • Replied by admin on Saturday, October 02 2021, 02:27 PM · Hide· #18
    Yes I'm still testing
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Saturday, October 02 2021, 02:31 PM · Hide· #19
    I have uploded the fix to your website. Now minifrontpagepro should work with images path with foreword slash. Can you check it please?
    https://www.dropbox.com/s%2Ft0hzdlcid3nyyh9%2Farchief-2021-frontpro%25202021-10-02%252021-30-15.png?raw=1
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by milian on Saturday, October 02 2021, 02:36 PM · Hide· #20
    I placed all the images back. Now you can see theJMedia filled.
    What happened? The whole image folder (dir) eas empty.
  •  
  • Replied by milian on Saturday, October 02 2021, 02:51 PM · Hide· #21
    Yes it works! Thanks a lot for your efforts! Grat work.
    Put you the update in the downloads on your website?
    And you have an update of mod_minifrontpagepro_j3 / j4 for me.
  •  
  • Replied by admin on Saturday, October 02 2021, 02:56 PM · Hide· #22
    1. I was deleting all thumbnail images under the folder images/thumbnails/mod_minifrontpagepro.
    2. Then I changed image path on Wij Zijn verhuisd article to have foreword slash
    3. This page https://ja30-bp.maxfolmer.nl/nieuwsbrieven/archief-2021-frontpro error again
    4. I uploaded the patched version of minifrontpage pro
    5. Thumbnails are now generated into folder images/thumbnails/mod_minifrontpagepro
    6. This page https://ja30-bp.maxfolmer.nl/nieuwsbrieven/archief-2021-frontpro is now working properly

    Can you check it please?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Saturday, October 02 2021, 02:57 PM · Hide· #23
    Put you the update in the downloads on your website?
    And you have an update of mod_minifrontpagepro_j3 / j4 for me.

    Yes, I'm currently working for minifrontpagepro update (especially for Joomla 4 support). The current patched version will be included in the upcoming update
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by milian on Saturday, October 02 2021, 03:03 PM · Hide· #24
    Yes please.
    But where do I find (see) the Downloads folder?
    Or do you place a download folder in /images/ ?
    That's ok.
  •  
  • Replied by admin on Saturday, October 02 2021, 03:06 PM · Hide· #25
    But where do I find (see) the Downloads folder?

    I'm not sure, what do you mean by Downloads folder?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by milian on Saturday, October 02 2021, 03:09 PM · Hide· #26
    "Put you the update in the downloads on your website? "
    I thouhgt you upload an update on my website.
    Whas I wrong?
  •  
  • Replied by admin on Saturday, October 02 2021, 03:26 PM · Hide· #27
    Ah, I mean I installed the patched version to your website but haven't put that version on templateplazza.com yet, because I'm still working on other improvements. Once I upload the update to templateplazza, you will be able to download the update from this page : https://www.templateplazza.com/your-download
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by milian on Saturday, October 02 2021, 03:43 PM · Hide· #28
    Great. And thanks for all the efforts.
    I close here now for today.
    It becomes evening here in Holland.
    Regards,
    Milian
  •  
  • Replied by admin on Saturday, October 02 2021, 03:52 PM · Hide· #29
    Sure Milian. Have a great weekend ;)
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by milian on Wednesday, October 13 2021, 10:38 AM · Hide· #30
    Hi,
    See this tread October 02 2021.
    Did you placed the modified mod_minifrontpagepro_j3 / j4 already?
    --"The issue is also because of that you are using JCE that is not automatically replace the foreward slash as TinyMCE does"--
    So that we can set the image location without the errors (witch you solved on my website)
    Regards, Milian
  •  
  •  
    Replied by admin on Thursday, October 14 2021, 08:16 AM · Hide· #31
    Hi Milian,
    Actually I'm still working on a joomla 4 compatibility issue on infinity theme, but it looks like it will take longer than expected as it seems there is still some issue with Joomla 4 itself, so I think I will pending it right now and release the update very soon.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
Your Response
Please login first in order for you to submit comments