Website crashes after upgrading from MFP 1.5.1. to 2.0.0.

Hi there,

On one of my websites that use MFP the website crashes after upgrading to version 2.0.0. It is the only website that uses a child template, so maybe that may be the cause of the problem.
PS: I restored a backup with version 1.5.1. in order to make the website work again. I hope you have enough information in the stacktrace below:

Kind regards,
Peter

This is the stacktrace:

Class "Joomla\Module\Minifrontpagepro\Site\Helper\MinifrontpageproHelper" not found

Call stack
# Function Location
1 () JROOT/templates/cassiopeia_dwrbouw/html/mod_minifrontpagepro/newsy.php:123
2 require() JROOT/modules/mod_minifrontpagepro/mod_minifrontpagepro.php:51
3 include() JROOT/libraries/src/Dispatcher/ModuleDispatcher.php:54
4 Joomla\CMS\Dispatcher\ModuleDispatcher::Joomla\CMS\Dispatcher\{closure}() JROOT/libraries/src/Dispatcher/ModuleDispatcher.php:57
5 Joomla\CMS\Dispatcher\ModuleDispatcher->dispatch() JROOT/libraries/src/Helper/ModuleHelper.php:295
6 Joomla\CMS\Helper\ModuleHelper::renderRawModule() JROOT/libraries/src/Helper/ModuleHelper.php:167
7 Joomla\CMS\Helper\ModuleHelper::renderModule() JROOT/libraries/src/Document/Renderer/Html/ModuleRenderer.php:102
8 Joomla\CMS\Document\Renderer\Html\ModuleRenderer->render() JROOT/libraries/src/Document/HtmlDocument.php:706
9 Joomla\CMS\Document\HtmlDocument->countModules() JROOT/templates/cassiopeia_dwrbouw/index.php:186
10 require() JROOT/libraries/src/Document/HtmlDocument.php:779
11 Joomla\CMS\Document\HtmlDocument->_loadTemplate() JROOT/libraries/src/Document/HtmlDocument.php:838
12 Joomla\CMS\Document\HtmlDocument->_fetchTemplate() JROOT/libraries/src/Document/HtmlDocument.php:641
13 Joomla\CMS\Document\HtmlDocument->parse() JROOT/libraries/src/Application/CMSApplication.php:1025
14 Joomla\CMS\Application\CMSApplication->render() JROOT/libraries/src/Application/SiteApplication.php:802
15 Joomla\CMS\Application\SiteApplication->render() JROOT/libraries/src/Application/CMSApplication.php:284
16 Joomla\CMS\Application\CMSApplication->execute() JROOT/includes/app.php:63
17 require_once() JROOT/index.php:32
Resolved
The discussion has been resolved.
       
  • Replied by admin on Friday, July 01 2022, 01:24 PM · Hide· #1
    Hi Peter, Does your website have template override for minifrontpage?
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by pjwouda on Friday, July 01 2022, 01:28 PM · Hide· #2
    Yes, newsy.php is the override in html/mod_minifrontpagepro/newsy.php
  •  
  • Replied by admin on Friday, July 01 2022, 01:32 PM · Hide· #3
    Hmm as the new version is using the different code for Joomla 4 it will need some code update on the override file. Let me check on it and back to you soon
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by admin on Friday, July 01 2022, 01:47 PM · Hide· #4
    I have made some changes to your override file so it should be working good now. Please check.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by pjwouda on Friday, July 01 2022, 01:53 PM · Hide· #5
    Works fine now, thanks!
    I forgot about the override, that was the difference between the other sites.

    One question: will it be possible in the future to update in the Joomla Updatemanager? Now we have to download manualy, unzip, and install the right version.

    Regards,
    Peter
  •  
  • Replied by admin on Friday, July 01 2022, 02:00 PM · Hide· #6
    Works fine now, thanks!
    I forgot about the override, that was the difference between the other sites.
    Glad it worked out;)

    One question: will it be possible in the future to update in the Joomla Updatemanager? Now we have to download manualy, unzip, and install the right version.

    Adding auto update manager will add some complexity to the module and our system while I just want to keep the module simple. Maybe I will add it in the future but not in near future I think
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by pjwouda on Friday, July 01 2022, 02:07 PM · Hide· #7
    OK, thank you for the answer. I am using MySites.guru to auto-update about 80 websites (with 6 using MFP so far), so an auto-update option would be a reason for me to use it on more websites. But as long as there are no updates every week, it is not a big deal ;)

    Thanks for your help and, have a nice weekend!
  •  
  •  
    Replied by admin on Friday, July 01 2022, 02:11 PM · Hide· #8
    Ah I see. ;) Have a nice weekend too!
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
Your Response
Please login first in order for you to submit comments