Quote

We're also available for Custom Joomla Development

Hire us now

XTypo compatibility with PHP 7.0

Hello,

I just wanted to ask if XTypo is compatible with PHP 7.0. Has it been tested?

Thank you for confirming,
George
Resolved
The discussion has been resolved.
       
  • Replied by admin on Tuesday, August 30 2016, 08:20 AM · Hide· #1
    thank you for your reply.
    It works perfectly. Thank you very much.
    You can close the case.

    No problem at all ;)

    but it would be great if the fix is provided as an update together with any other PHP 7 code updates that might be needed!

    Done. The update is now available in the extension page ;)
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by ensigcom on Monday, August 29 2016, 01:55 PM · Hide· #2
    I have also been using it with Joomla 3.6.2 and PHP 7.0.10 without issues. I haven't come across the above notice when i enabled the error reporting (otherwise i would have reported it), but it would be great if the fix is provided as an update together with any other PHP 7 code updates that might be needed!

    Thank you for the great extension :)
  •  
  • Replied by guillenphoto on Monday, August 29 2016, 01:48 PM · Hide· #3
    Hello,

    thank you for your reply.
    It works perfectly. Thank you very much.
    You can close the case.

    Have a nice day.
  •  
  • Replied by admin on Monday, August 29 2016, 04:58 AM · Hide· #4
    Hi, can you try to open the file ../plugins/content/xtypo/xtypo.php
    at lines you will see this code :
    function plgContentxtypo(&$subject, $params){

    could you try to change that to :
    function __construct(&$subject, $params){


    and let me know the result
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
  •  
  • Replied by guillenphoto on Saturday, August 27 2016, 10:59 PM · Hide· #5
    Hello,

    I am running my website under PHP 7. I have an error with Xtyp.
    I have attached a screen copy of the problem.
    I hope you will find a solution because your plugin is very useful.

    Attachments:

  •  
  •  
    Replied by admin on Monday, April 04 2016, 02:10 AM · Hide· #6
    Hi, I haven't been able to install joomla 3.5 with php 7 in my local environtment yet. If you could, please try yourself and let us know if there's any issue with that.
    Please post rating at the Joomla! Extensions Directory - http://extensions.joomla.org/profile/profile/details/264
Your Response
Please login first in order for you to submit comments